Delayed Mail Delivery to Microsoft Mail Services

Incident Report for 14IP

Resolved

Mail continues to flow normally and at expected deliverability rates without delays.
Posted Aug 27, 2026 - 09:18 CDT

Update

While we are still seeing delays in delivering mail to Microsoft mail services, acceptance rates are continually improving and the current backlog has been almost completely processed. We are continuing to monitor for performance and will close this out once we are satisfied with consistent delivery rates.
Posted Aug 26, 2026 - 09:07 CDT

Update

We continue to monitor for improved mail delivery rates to Microsoft mail services.
Posted Aug 25, 2026 - 21:24 CDT

Monitoring

Queue processing continues successfully, though slowly as Microsoft accepts mail from our platform(s). We expect to see acceptance rates increase over time as well. Engineering continues to monitor activity and delivery improvements.
Posted Aug 25, 2026 - 15:55 CDT

Investigating

We are seeing an increase in mail delivery delays for messages originating from our platforms towards Microsoft mail services.
Posted Aug 25, 2026 - 15:51 CDT
This incident affected: SendFax.to (Fax Service) and CloudPBX (Clearly Cloud Canada, Clearly Cloud USA - w, Clearly Cloud USA - r).